Skip to main content
VulnerabilityPublished

CVE-2026-121387: FreeRDP · Out-of-bounds Read

Affects FreeRDPSource CVE Database V5

0
Compare

Not known to be exploited · CVSS 5.3 Medium : upgrade to 3.32.2 when convenient.

Data as of 3 Nov 2026, 15:00 UTC

CVSS 4.0 base score
5.3Medium
How severe the flaw is on the 0–10 CVSS scale.

Thin evidence

One scorer or none
CVSS scores by source
CNA (VulnCheck)CVSS 4.05.3
CNA (VulnCheck)CVSS 3.14.3
Patch
Available – fixed in 3.32.2
CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:P/VC:N/VI:N/VA:L/SC:N/SI:N/SA:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 3 Nov 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 3 Nov 2026.

What to do

Upgrade FreeRDP to 3.32.2.

Affected software

ProductAffectedFixed in
FreeRDPFreeRDPAffected
  • >=2.0.0 <3.32.2
Fixed in
  • 3.32.2

AI-suggested

Upgrade FreeRDP to version 3.32.2 or later, where this vulnerability is fixed. Until then, avoid connecting to untrusted RDP servers that might exploit this flaw.

Description

FreeRDP versions from 2.0.0 up to but not including 3.32.2 contain an out-of-bounds read vulnerability in the audio decoding function freerdp_dsp_decode_gsm610. This flaw allows malicious RDP servers to send specially crafted truncated GSM610 audio frames, causing the client to read beyond the intended audio buffer. Such malformed input can lead to client crashes. The issue is fixed in FreeRDP version 3.32.2.

References

Community reviews

Loading reviews…