CVE-2026-121416: surrealdb · Improper Access Control
Affects surrealdbSource CVE Database V5
Not known to be exploited · CVSS 7.1 High : upgrade to 3.3.1 soon.
Data as of 3 Nov 2026, 14:58 UTC
Thin evidence
One scorer or none| CNA (VulnCheck) | CVSS 4.0 | 7.1 |
|---|---|---|
| CNA (VulnCheck) | CVSS 3.1 | 7.1 |
- Patch
- Available – fixed in 3.3.1
CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:H/VI:L/VA:N/SC:N/SI:N/SA:NExploitation evidence
Disclosed: evidence found.
CVE published 3 Nov 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 3 Nov 2026.
What to do
Upgrade surrealdb to 3.3.1.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| surrealdbsurrealdb | Affected
| Fixed in
|
crates.iosurrealdbpkg:cargo/surrealdbOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
Upgrade SurrealDB to version 3.3.1 or later, where this vulnerability is fixed. No other mitigation or temporary workaround is indicated by the vendor advisory.
Description
SurrealDB versions 2.0.0 up to but not including 3.3.1 have an improper access control vulnerability where the --deny-funcs restrictions are not enforced on method-style function calls in the streaming engine. This allows authenticated users who can submit queries to execute functions that should be denied, such as reading and writing file bucket data, bypassing intended restrictions.