Skip to main content
VulnerabilityPublished

CVE-2026-121419: surrealdb · Improper Privilege Management

Affects surrealdbSource CVE Database V5

0
Compare

Not known to be exploited · CVSS 8.6 High : upgrade to 3.3.0 soon.

Data as of 3 Nov 2026, 14:58 UTC

CVSS 4.0 base score
8.6High
How severe the flaw is on the 0–10 CVSS scale.

Thin evidence

One scorer or none
CVSS scores by source
CNA (VulnCheck)CVSS 4.08.6
CNA (VulnCheck)CVSS 3.18.1
Patch
Available – fixed in 3.3.0
CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:H/VI:H/VA:N/SC:N/SI:N/SA:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 3 Nov 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 3 Nov 2026.

What to do

Upgrade surrealdb to 3.3.0.

Affected software

ProductAffectedFixed in
surrealdbsurrealdbAffected
  • >=3.1.0 <3.3.0
Fixed in
  • 3.3.0
crates.iosurrealdbpkg:cargo/surrealdbOther threatsAffected
  • >=3.1.0 <3.3.0
Fixed in
  • 3.3.0

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Upgrade SurrealDB to version 3.3.0 or later, where this vulnerability has been fixed. No other mitigation or workaround is indicated. Applying the official fix eliminates the risk of session hijacking via this flaw.

Description

SurrealDB versions 3.1.0 up to but not including 3.3.0 have an improper authentication vulnerability. The issue arises because the MCP BoundSubject fingerprint uses the access method name rather than a per-user identity for JWT/Bearer tokens. This flaw allows attackers possessing a valid low-privilege token for the same access method and a victim's mcp-session-id to hijack the victim's session and execute MCP tools with the victim's roles and permissions. The vulnerability is rated high severity with a CVSS score of 8.6 and was fixed in version 3.3.0.

References

Community reviews

Loading reviews…