Skip to main content
VulnerabilityPublished

CVE-2026-121418: surrealdb · Incorrect Authorization

Affects surrealdbSource CVE Database V5

0
Compare

Not known to be exploited · CVSS 5.3 Medium : upgrade to 3.3.0 when convenient.

Data as of 3 Nov 2026, 14:58 UTC

CVSS 4.0 base score
5.3Medium
How severe the flaw is on the 0–10 CVSS scale.

Thin evidence

One scorer or none
CVSS scores by source
CNA (VulnCheck)CVSS 4.05.3
CNA (VulnCheck)CVSS 3.14.3
Patch
Available – fixed in 3.3.0
CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:L/VI:N/VA:N/SC:N/SI:N/SA:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 3 Nov 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 3 Nov 2026.

What to do

Upgrade surrealdb to 3.3.0.

Affected software

ProductAffectedFixed in
surrealdbsurrealdbAffected
  • >=3.1.0 <3.3.0
Fixed in
  • 3.3.0
crates.iosurrealdbpkg:cargo/surrealdbOther threatsAffected
  • >=3.1.0 <3.3.0
Fixed in
  • 3.3.0

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Upgrade SurrealDB to version 3.3.0 or later, where this incorrect authorization vulnerability is fixed. No other mitigation or workaround is indicated in the available data.

Description

SurrealDB versions 3.1.0 up to but not including 3.3.0 have an incorrect authorization vulnerability. This flaw allows users with record access to infer values of restricted fields by exploiting the streaming planner's use of indexes on fields with restrictive SELECT permissions. Attackers can perform full-text MATCHES, compound B-tree, or HNSW KNN queries against these restricted fields to deduce which records contain specific guessed values or nearest vectors. The vulnerability is fixed in version 3.3.0.

References

Community reviews

Loading reviews…