CVE-2026-121425: nodemailer · Improper Input Validation
Affects nodemailerSource CVE Database V5
Not known to be exploited · CVSS 8.3 High : upgrade to 10.1.4 soon.
Data as of 3 Nov 2026, 14:58 UTC
Thin evidence
One scorer or none| CNA (VulnCheck) | CVSS 4.0 | 8.3 |
|---|---|---|
| CNA (VulnCheck) | CVSS 3.1 | 6.5 |
- Patch
- Available – fixed in 10.1.4
CVSS:4.0/AV:N/AC:H/AT:P/PR:N/UI:N/VC:H/VI:L/VA:N/SC:N/SI:N/SA:NExploitation evidence
Disclosed: evidence found.
CVE published 3 Nov 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 3 Nov 2026.
What to do
Upgrade nodemailer to 10.1.4.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| nodemailernodemailer | Affected
| Fixed in
|
npmnodemailerpkg:npm/nodemailerOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
Upgrade Nodemailer to version 10.1.4 or later, where this parsing flaw is fixed. No other mitigations are indicated by the vendor advisory.
Description
Nodemailer versions from 3.0.0 up to but not including 10.1.4 contain a parsing flaw in the addressparser component. This flaw causes an RFC 5322 group to end prematurely at a semicolon inside quoted display names or comments. Attackers can exploit this by submitting crafted group addresses that pass conformant validators, enabling redirection of mail to attacker-chosen recipients and bypassing recipient allow lists. The issue is fixed in version 10.1.4.