CVE-2026-121441: bytecodealliance wasmtime · HTTP Request/Response Smuggling
Affects bytecodealliance wasmtimeSource CVE Database V5
Not known to be exploited · CVSS 6.3 Medium · fixed in 49.0.4 : update bytecodealliance wasmtime when convenient.
Data as of 3 Nov 2026, 14:58 UTC
Thin evidence
One scorer or none| CNA (VulnCheck) | CVSS 4.0 | 6.3 |
|---|---|---|
| CNA (VulnCheck) | CVSS 3.1 | 3.7 |
- Patch
- Available – fixed in 49.0.4, 48.0.7, 36.0.19
CVSS:4.0/AV:N/AC:H/AT:P/PR:N/UI:N/VC:N/VI:L/VA:N/SC:N/SI:N/SA:NExploitation evidence
Disclosed: evidence found.
CVE published 3 Nov 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 3 Nov 2026.
What to do
Upgrade bytecodealliance wasmtime to 49.0.4, 48.0.7 or 36.0.19.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| bytecodealliancewasmtime | Affected
| Fixed in
|
| bytecodealliancewasmtime | Affected
| Fixed in
|
| bytecodealliancewasmtime | Affected
| Fixed in
|
crates.iowasmtimepkg:cargo/wasmtimeOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
Apply the official fixes by upgrading Wasmtime to versions 36.0.19, 48.0.7, or 49.0.4 or later. These versions contain patches that address the request smuggling vulnerability in wasi-http. No other mitigation actions are indicated by the vendor advisory.
Description
CVE-2026-121441 is a vulnerability in the wasi-http component of Wasmtime that allows malicious guests to set multiple conflicting content-length headers in HTTP requests. This request smuggling flaw affects Wasmtime versions before 36.0.19, versions from 37.0.0 up to but not including 48.0.7, and versions from 49.0.0 up to but not including 49.0.4. Exploiting this issue can cause the host to send HTTP requests with conflicting content-length values, potentially enabling request smuggling through servers or intermediaries that do not reject such requests. The vulnerability has a CVSS 4.0 base score of 6.3, indicating medium severity. Fixes are available in Wasmtime versions 36.0.19, 48.0.7, and 49.0.4.