CVE-2026-121652: AWS maplibre-gl-js-amplify · Cross-site Scripting
Affects AWS maplibre-gl-js-amplifySource CVE Database V5
Not known to be exploited · CVSS 5.4 Medium : upgrade to 4.0.3 when convenient.
Data as of 3 Nov 2026, 19:13 UTC
Thin evidence
One scorer or none| CNA (AMZN) | CVSS 3.1 | 5.4 |
|---|---|---|
| CNA (AMZN) | CVSS 4.0 | 4.8 |
- Patch
- Available – fixed in 4.0.3
CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:NExploitation evidence
Disclosed: evidence found.
CVE published 3 Nov 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 3 Nov 2026.
What to do
Upgrade AWS maplibre-gl-js-amplify to 4.0.3.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| AWSmaplibre-gl-js-amplify | Affected
| Fixed in
|
AI-suggested
Users should upgrade to AWS Amplify maplibre-gl-js-amplify version 4.0.3 or later to remediate this vulnerability. Since this is a cloud service component, AWS manages remediation for the cloud-hosted service; however, for self-hosted or embedded usages, applying the official fix is necessary.
Description
CVE-2026-121652 is a cross-site scripting (XSS) vulnerability in AWS Amplify's maplibre-gl-js-amplify component before version 4.0.3. The flaw allows remote authenticated users to inject arbitrary web scripts or HTML via certain properties in GeoJSON feature data or the geofenceId value. AWS has fixed this issue in version 4.0.3.