CVE-2026-5429: AWS Kiro IDE · Cross-site Scripting
Affects AWS Kiro IDESource CVE Database V5
Not known to be exploited · CVSS 7.8 High : upgrade to 0.8.140 soon.
Data as of 30 Oct 2026, 11:34 UTC
- EPSS
- 0.1% chance of exploitation in 30 days – higher than 4% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 0.8.140
CVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:HExploitation evidence
Disclosed: evidence found.
CVE published 2 Apr 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 24 Oct 2026.
What to do
Upgrade AWS Kiro IDE to 0.8.140.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| AWSKiro IDE | Affected
| Fixed in
|
AI-suggested
A fix is available by upgrading AWS Kiro IDE to version 0.8.140 or later. Users should apply this update to remediate the vulnerability. No additional mitigations are specified or required if the update is applied.
Description
CVE-2026-5429 is a high-severity cross-site scripting (XSS) vulnerability in AWS Kiro IDE versions before 0.8.140. It arises from improper input neutralization during web page generation in the Kiro Agent webview, allowing remote unauthenticated attackers to execute arbitrary code via crafted color theme names when a local user opens a trusted workspace. The vulnerability requires user interaction to trust the workspace. Upgrading to version 0.8.140 or later mitigates the issue.