Skip to main content
VulnerabilityPublished

CVE-2026-121749: nvm · Argument Injection

Affects nvmSource CVE Database V5

0
Compare

Not known to be exploited · CVSS 4.6 Medium : upgrade to 0.41.0 when convenient.

Data as of 5 Nov 2026, 00:16 UTC

CVSS 4.0 base score
4.6Medium
How severe the flaw is on the 0–10 CVSS scale.

Thin evidence

One scorer or none
CVSS scores by source
CNA (harborist)CVSS 4.04.6
CNA (harborist)CVSS 3.13.3
Patch
Available – fixed in 0.41.0
CVSS:4.0/AV:L/AC:L/AT:N/PR:N/UI:A/VC:L/VI:N/VA:N/SC:N/SI:N/SA:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 4 Nov 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 5 Nov 2026.

What to do

Upgrade nvm to 0.41.0.

Affected software

ProductAffectedFixed in
nvm-shnvmAffected
  • >=0.5.0 <0.41.0
Fixed in
  • 0.41.0
GitHubnvmpkg:github/nvmOther threatsAffected
  • >=0.5.0 <0.41.0
Fixed in
  • 0.41.0

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Upgrade nvm to version 0.41.0 or later, where the vulnerability is fixed by passing version patterns to grep with the '-e' option. No other mitigation is required as the fix addresses the root cause. Users should avoid using vulnerable versions and ensure .nvmrc files are from trusted sources.

Description

Node Version Manager (nvm) versions 0.5.0 through 0.40.8 contain an argument injection vulnerability (CWE-88) where version patterns from a .nvmrc file starting with '-' are interpreted as grep options. This causes unintended recursive directory searches, potentially leaking sensitive data such as npm tokens from symlinked files to terminal output and logs. The issue is fixed in version 0.41.0 by passing version patterns to grep with the '-e' option.

References

Community reviews

Loading reviews…