CVE-2026-121751: nvm · OS Command Injection
Affects nvmSource CVE Database V5
Not known to be exploited · CVSS 2.1 Low : upgrade to 0.41.0 when convenient.
Data as of 5 Nov 2026, 00:16 UTC
Thin evidence
One scorer or none| CNA (harborist) | CVSS 4.0 | 2.1 |
|---|---|---|
| CNA (harborist) | CVSS 3.1 | 3.1 |
- Patch
- Available – fixed in 0.41.0
CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:A/VC:N/VI:L/VA:N/SC:N/SI:N/SA:NExploitation evidence
Disclosed: evidence found.
CVE published 4 Nov 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 5 Nov 2026.
What to do
Upgrade nvm to 0.41.0.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| nvm-shnvm | Affected
| Fixed in
|
GitHubnvmpkg:github/nvmOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
Upgrade nvm to version 0.41.0 or later, which includes a fix that restricts arithmetic evaluation to numeric offsets and discards invalid version strings from the mirror. Avoid using untrusted or compromised mirrors, and prefer HTTPS mirrors to reduce the risk of man-in-the-middle attacks. No other mitigations are indicated by the vendor advisory.
Description
Node Version Manager (nvm) versions 0.39.6 through 0.40.8 contain an OS command injection vulnerability in the handling of remote LTS aliases. The vulnerability arises because the version column from the mirror's index.tab file is stored without validation and later evaluated in shell arithmetic, allowing command substitution execution under bash and zsh. Exploitation requires use of a hostile mirror or man-in-the-middle attack and running affected nvm commands. The issue is fixed in version 0.41.0 by restricting arithmetic evaluation to numeric offsets and dropping invalid version strings.