Gov.nsa.emissary:emissary: Emissary has an OS Command Injection via Unvalidated IN_FILE_ENDING / OUT_FILE_ENDING in
Affects gov.nsa.emissary:emissarySource GCVE Database
Not known to be exploited · CVSS 8.8 High : upgrade to 8.43.0 soon.
Data as of 5 Nov 2026, 00:01 UTC
- EPSS
- 0.8% chance of exploitation in 30 days – higher than 58% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 8.43.0
CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:C/C:H/I:H/A:HExploitation evidence
Disclosed: evidence found.
CVE published 18 Apr 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 5 Nov 2026.
What to do
Upgrade gov.nsa.emissary:emissary to 8.43.0.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| Mavengov.nsa.emissary:emissary | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
A patch is available in Emissary version 8.43.0 that addresses this vulnerability. Users should upgrade to version 8.43.0 or later to remediate the issue. No additional mitigation steps are required if the patch is applied.
Description
A command injection vulnerability exists in the Emissary framework (CVE-2026-35582) due to unvalidated IN_FILE_ENDING and OUT_FILE_ENDING configuration keys. These values are concatenated into temporary file paths without sanitization and then substituted directly into shell commands executed via /bin/sh -c, allowing arbitrary OS command execution by a place author. No additional runtime privileges or network access are required. The vulnerability affects Emissary versions prior to 8.43.0 and is fixed in version 8.43.0.
References
- github.com/NationalSecurityAgency/emissary/security/advisories/GHSA-3p24-9x7v-7789 (opens in a new tab)
- nvd.nist.gov/vuln/detail/CVE-2026-35582 (opens in a new tab)
- github.com/NationalSecurityAgency/emissary/commit/1faf33f2494c0128f250d7d2e8f2da99bbd32ae8 (opens in a new tab)
- github.com/NationalSecurityAgency/emissary (opens in a new tab)
- github.com/NationalSecurityAgency/emissary/releases/tag/8.43.0 (opens in a new tab)