Skip to main content
VulnerabilityPublished Updated

CVE-2026-35582: NationalSecurityAgency emissary · OS Command Injection

Affects NationalSecurityAgency emissarySource CVE Database V5

0
Compare

Not known to be exploited · CVSS 8.8 High : upgrade to 8.43.0 soon.

Data as of 30 Oct 2026, 06:59 UTC

CVSS 3.1 base score
8.8High
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.8% chance of exploitation in 30 days – higher than 58% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 8.43.0
CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:C/C:H/I:H/A:H

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 18 Apr 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 29 Oct 2026.

What to do

Upgrade emissary and nationalsecurityagency/emissary to 8.43.0.

Affected software

ProductAffectedFixed in
NationalSecurityAgencyemissaryAffected
  • <8.43.0
Fixed in
  • 8.43.0
GitHubnationalsecurityagency/emissarypkg:github/nationalsecurityagency/emissaryOther threatsAffected
  • <8.43.0
Fixed in
  • 8.43.0

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

This vulnerability is fixed in Emissary version 8.43.0. Users should upgrade to version 8.43.0 or later to remediate this issue. There is no safe mitigation available for downstream implementors in earlier versions because the framework does not provide escaping or validation for file ending inputs. Until upgrading, restrict place configuration file write access to trusted users only. Patch status is confirmed by the vendor advisory indicating the fix in version 8.43.0.

Description

Emissary is a P2P based data-driven workflow engine. In versions 8.42.0 and below, Executrix.getCommand() is vulnerable to OS command injection because it interpolates temporary file paths into a /bin/sh -c shell command string without any escaping or input validation. The IN_FILE_ENDING and OUT_FILE_ENDING configuration keys flow directly into these paths, allowing a place author who can write or modify a .cfg file to inject arbitrary shell metacharacters that execute OS commands in the JVM process's security context. The framework already sanitizes placeName via an allowlist before embedding it in the same shell string, but applies no equivalent sanitization to file ending values. No runtime privileges beyond place configuration authorship, and no API or network access, are required to exploit this vulnerability. This is a framework-level defect with no safe mitigation available to downstream implementors, as Executrix provides neither escaping nor documented preconditions against metacharacters in file ending inputs. This issue has been fixed in version 8.43.0.

References

Community reviews

Loading reviews…