Skip to main content
VulnerabilityPublished Updated

CVE-2026-35581: Gov.nsa.emissary:emissary: Emissary has a Command Injection via PLACE_NAME Configuration in Executrix

Affects gov.nsa.emissary:emissarySource GCVE Database

0
Compare
Authoritative record:CVE-2026-35581· High 7.2

Not known to be exploited · CVSS 7.2 High : upgrade to 8.39.0 soon.

Data as of 5 Nov 2026, 00:01 UTC

CVSS 3.1 base score
7.2High
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.5% chance of exploitation in 30 days – higher than 48% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 8.39.0
CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:H/I:H/A:H

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 7 Apr 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 5 Nov 2026.

What to do

Upgrade gov.nsa.emissary:emissary to 8.39.0.

Affected software

ProductAffectedFixed in
Mavengov.nsa.emissary:emissaryAffected
  • <8.39.0
Fixed in
  • 8.39.0

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

A fix is available in Emissary version 8.39.0, which replaces the insufficient sanitization with an allowlist regex that strips all shell metacharacters from the PLACE_NAME parameter. Users should upgrade to version 8.39.0 or later. If immediate upgrade is not possible, ensure that PLACE_NAME values in configuration files contain only alphanumeric characters, underscores, and hyphens to avoid injection.

Description

CVE-2026-35581 is a command injection vulnerability in the Executrix utility class of the Emissary project. The vulnerability arises because the PLACE_NAME configuration parameter is sanitized only by replacing spaces with underscores, allowing shell metacharacters to pass through into commands executed via /bin/sh -c. This enables an attacker with the ability to control configuration values to execute arbitrary commands on the host. The issue is fixed in Emissary release 8.39.0 by applying an allowlist regex that replaces all non-alphanumeric, non-underscore, and non-hyphen characters with underscores.

References

Community reviews

Loading reviews…