Skip to main content
VulnerabilityPublished

CVE-2026-35581: NationalSecurityAgency emissary · OS Command Injection

Affects NationalSecurityAgency emissarySource CVE Database V5

0
Compare

Not known to be exploited · CVSS 7.2 High : upgrade to 8.39.0 soon.

Data as of 30 Oct 2026, 06:59 UTC

CVSS 3.1 base score
7.2High
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.5% chance of exploitation in 30 days – higher than 46% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 8.39.0
CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:H/I:H/A:H

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 7 Apr 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 29 Oct 2026.

What to do

Upgrade emissary and nationalsecurityagency/emissary to 8.39.0.

Affected software

ProductAffectedFixed in
NationalSecurityAgencyemissaryAffected
  • <8.39.0
Fixed in
  • 8.39.0
GitHubnationalsecurityagency/emissarypkg:github/nationalsecurityagency/emissaryOther threatsAffected
  • <8.39.0
Fixed in
  • 8.39.0

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Upgrade Emissary to version 8.39.0 or later where this vulnerability is fixed. Until upgraded, avoid using untrusted input in the PLACE_NAME parameter or any configuration values that influence shell command construction.

Description

CVE-2026-35581 is an OS command injection vulnerability in the NationalSecurityAgency's Emissary product prior to version 8.39.0. The Executrix utility class improperly sanitizes the PLACE_NAME parameter by only replacing spaces with underscores, allowing shell metacharacters to be injected into commands executed via /bin/sh -c. This flaw enables an attacker with high privileges to execute arbitrary commands with high impact on confidentiality, integrity, and availability. The vulnerability is fixed in version 8.39.0.

References

Community reviews

Loading reviews…