CVE-2026-121967: coder · Path Traversal
Affects coderSource CVE Database V5
Not known to be exploited · CVSS 2.3 Low : upgrade to 2.37.5 when convenient.
Data as of 4 Nov 2026, 15:58 UTC
Thin evidence
One scorer or none| CNA (VulnCheck) | CVSS 4.0 | 2.3 |
|---|---|---|
| CNA (VulnCheck) | CVSS 3.1 | 4.9 |
- Patch
- Available – fixed in 2.37.5, 2.36.8, 2.35.10 +3
CVSS:4.0/AV:N/AC:H/AT:P/PR:L/UI:N/VC:L/VI:L/VA:N/SC:L/SI:L/SA:NExploitation evidence
Disclosed: evidence found.
CVE published 4 Nov 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 4 Nov 2026.
What to do
Upgrade to a fixed release listed under Affected software.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| codercoder | Affected
| Fixed in
|
| codercoder | Affected
| Fixed in
|
| codercoder | Affected
| Fixed in
|
| codercoder | Affected
| Fixed in
|
| codercoder | Affected
| Fixed in
|
| codercoder | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
A fix is available in Coder versions 2.29.22, 2.34.13, 2.35.10, 2.36.8, 2.37.5, and 2.38.1. Users should upgrade to these or later versions to remediate the vulnerability. No additional mitigation steps are indicated.
Description
Coder versions 2.28.0 before 2.29.22, 2.30.0 before 2.34.13, 2.35.0 before 2.35.10, 2.36.0 before 2.36.8, 2.37.0 before 2.37.5, and 2.38.0 before 2.38.1 contain a path traversal vulnerability in the AI Gateway passthrough router. Authenticated users can exploit this by sending percent-encoded dot segments to access unintended provider endpoints using the deployment's centrally managed provider key. The vulnerability is fixed in the listed later versions.