Skip to main content
VulnerabilityPublished

CVE-2026-122127: CESNET ipfixcol2 · Out-of-bounds Write

Affects CESNET ipfixcol2Source CVE Database V5

0
Compare

Not known to be exploited · CVSS 8.7 High : upgrade to 2.9.0 soon.

Data as of 4 Nov 2026, 21:42 UTC

CVSS 4.0 base score
8.7High
How severe the flaw is on the 0–10 CVSS scale.

Thin evidence

One scorer or none
CVSS scores by source
CNA (VulnCheck)CVSS 4.08.7
CNA (VulnCheck)CVSS 3.17.5
Patch
Available – fixed in 2.9.0
CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:N/VA:H/SC:N/SI:N/SA:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 4 Nov 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 4 Nov 2026.

What to do

Upgrade ipfixcol2 and cesnet/ipfixcol2 to 2.9.0.

Affected software

ProductAffectedFixed in
CESNETipfixcol2Affected
  • >=2.7.1 <2.9.0
Fixed in
  • 2.9.0
GitHubcesnet/ipfixcol2pkg:github/cesnet/ipfixcol2Other threatsAffected
  • <2.9.0
Fixed in
  • 2.9.0

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Upgrade CESNET ipfixcol2 to version 2.9.0 or later, where this vulnerability is fixed. No other mitigations are indicated by the vendor advisory.

Description

CESNET ipfixcol2 versions 2.7.1 up to but not including 2.9.0 contain a heap-based buffer overflow vulnerability in the Lz4Decoder.cpp component. This flaw allows unauthenticated network peers to write beyond allocated heap buffers by manipulating buffer size parameters, potentially crashing the collector or causing other memory corruption issues. The vulnerability is fixed in version 2.9.0.

References

Community reviews

Loading reviews…