Skip to main content
VulnerabilityPublished

CVE-2026-122299: jelmer dulwich · Improper Preservation of Consistency Between Independent Representations of Shared State

Affects jelmer dulwichSource CVE Database V5

0
Compare

Not known to be exploited · CVSS 8.6 High : upgrade to 1.2.20 soon.

Data as of 5 Nov 2026, 00:16 UTC

CVSS 4.0 base score
8.6High
How severe the flaw is on the 0–10 CVSS scale.

Thin evidence

One scorer or none
CVSS scores by source
CNA (VulnCheck)CVSS 4.08.6
CNA (VulnCheck)CVSS 3.18.8
Patch
Available – fixed in 1.2.20
CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:A/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 4 Nov 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 5 Nov 2026.

What to do

Upgrade jelmer dulwich to 1.2.20.

Affected software

ProductAffectedFixed in
jelmerdulwichAffected
  • <1.2.20
Fixed in
  • 1.2.20
GitHubdulwichpkg:github/dulwichOther threatsAffected
  • <1.2.20
Fixed in
  • 1.2.20

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

A fixed version of Dulwich is available starting from 1.2.20. Users and projects, including Poetry 2.5.1 users, should upgrade Dulwich to version 1.2.20 or later to resolve this vulnerability. Until upgraded, users should be aware of the risk of unreviewed code execution when installing dependencies via Poetry using Dulwich. No vendor advisory indicates alternative mitigations or that the issue is already mitigated.

Description

Dulwich versions before 1.2.20 have a commit object parsing vulnerability where the parsing logic resolves duplicate tree headers incorrectly compared to core git. This causes Poetry 2.5.1, which uses Dulwich by default, to potentially check out attacker-controlled code that differs from what reviewers and CI systems see, enabling unreviewed code execution during install or build.

References

Community reviews

Loading reviews…