CVE-2026-122301: parse-server · Information Exposure
Affects parse-serverSource CVE Database V5
Not known to be exploited · CVSS 2.3 Low : upgrade to 9.10.6-alpha.6 when convenient.
Data as of 5 Nov 2026, 03:12 UTC
Thin evidence
One scorer or none| CNA (VulnCheck) | CVSS 4.0 | 2.3 |
|---|---|---|
| CNA (VulnCheck) | CVSS 3.1 | 3.1 |
- Patch
- Available – fixed in 9.10.6-alpha.6, 8.6.114
CVSS:4.0/AV:N/AC:L/AT:P/PR:L/UI:N/VC:L/VI:N/VA:N/SC:N/SI:N/SA:NExploitation evidence
Disclosed: evidence found.
CVE published 5 Nov 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 5 Nov 2026.
What to do
Upgrade parse-server to 9.10.6-alpha.6; parse-server to 8.6.114; parse-server to 9.10.6-alpha.6 or 8.6.114.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| parse-communityparse-server | Affected
| Fixed in
|
| parse-communityparse-server | Affected
| Fixed in
|
npmparse-serverpkg:npm/parse-serverOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
Upgrade parse-server to version 8.6.114 or later in the 8.x branch, or to 9.10.6-alpha.6 or later in the 9.x branch to apply the official fix. No other mitigation is required once patched.
Description
CVE-2026-122301 is a vulnerability in parse-community's parse-server where versions before 8.6.114 and 9.0.0 before 9.10.6-alpha.6 improperly expose field values in object creation responses to callers without read access. This occurs due to the server returning data set by Cloud Code triggers, schema defaults, and class default ACLs even when the caller lacks permission. An attacker with create permission can exploit this to access sensitive information.