Skip to main content
VulnerabilityPublished

CVE-2026-122303: kyverno · Missing Authorization

Affects kyvernoSource CVE Database V5

0
Compare

Not known to be exploited · CVSS 9.4 Critical : upgrade to 1.19.2 as a priority.

Data as of 5 Nov 2026, 03:12 UTC

CVSS 4.0 base score
9.4Critical
How severe the flaw is on the 0–10 CVSS scale.

Thin evidence

One scorer or none
CVSS scores by source
CNA (VulnCheck)CVSS 4.09.4
CNA (VulnCheck)CVSS 3.19.9
Patch
Available – fixed in 1.19.2
CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:H/VI:H/VA:H/SC:H/SI:H/SA:H

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 5 Nov 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 5 Nov 2026.

What to do

Upgrade kyverno to 1.19.2.

Affected software

ProductAffectedFixed in
kyvernokyvernoAffected
  • >=1.17.0 <1.19.2
Fixed in
  • 1.19.2
Gokyvernopkg:golang/kyvernoOther threatsAffected
  • >=1.17.0 <1.19.2
Fixed in
  • 1.19.2

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Upgrade Kyverno to version 1.19.2 or later, where this authorization bypass vulnerability is fixed. No other mitigations are indicated. Applying the official fix fully addresses the issue.

Description

Kyverno versions from 1.17.0 up to but not including 1.19.2 contain an authorization bypass vulnerability. This flaw allows namespace tenants to overwrite resources in other namespaces by exploiting the NamespacedMutatingPolicy mutate-existing targetMatchConstraints.expression. An attacker can craft a CEL map literal that fabricates a target with an attacker-chosen metadata.namespace, enabling the privileged background controller to overwrite critical cluster-wide resources such as Secrets, Deployments, or policies. The vulnerability is rated critical with a CVSS 4.0 score of 9.4 and has been fixed in version 1.19.2.

References

Community reviews

Loading reviews…