Skip to main content
VulnerabilityPublished

CVE-2026-122313: kyverno · Improper Privilege Management

Affects kyvernoSource CVE Database V5

0
Compare

Not known to be exploited · CVSS 9.4 Critical : upgrade to 1.19.2 as a priority.

Data as of 5 Nov 2026, 02:58 UTC

CVSS 4.0 base score
9.4Critical
How severe the flaw is on the 0–10 CVSS scale.

Thin evidence

One scorer or none
CVSS scores by source
CNA (VulnCheck)CVSS 4.09.4
CNA (VulnCheck)CVSS 3.19.9
Patch
Available – fixed in 1.19.2
CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:H/VI:H/VA:H/SC:H/SI:H/SA:H

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 5 Nov 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 5 Nov 2026.

What to do

Upgrade kyverno to 1.19.2.

Affected software

ProductAffectedFixed in
kyvernokyvernoAffected
  • >=1.17.0 <1.19.2
Fixed in
  • 1.19.2
Gokyvernopkg:golang/kyvernoOther threatsAffected
  • >=1.17.0 <1.19.2
Fixed in
  • 1.19.2

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Upgrade Kyverno to version 1.19.2 or later, where this vulnerability is fixed. No other mitigations are indicated in the vendor advisory.

Description

Kyverno versions from 1.17.0 up to but not including 1.19.2 contain a critical privilege escalation vulnerability. This flaw allows namespace-scoped tenants to modify resources in other namespaces by exploiting a lack of namespace checks in the NamespacedMutatingPolicy targetMatchConstraints.expression CEL output. Attackers can manipulate cluster-wide background controllers to alter RoleBindings, Roles, NetworkPolicies, and ConfigMaps in other namespaces. The vulnerability is fixed in version 1.19.2.

References

Community reviews

Loading reviews…