Skip to main content
VulnerabilityPublished

CVE-2026-123491: craftcms cms · SQL Injection

Affects craftcms cmsSource CVE Database V5

0
Compare

Not known to be exploited · CVSS 8.8 High : upgrade to 4.18.9 soon.

Data as of 6 Nov 2026, 15:25 UTC

CVSS 4.0 base score
8.8High
How severe the flaw is on the 0–10 CVSS scale.

Thin evidence

One scorer or none
CVSS scores by source
CNA (VulnCheck)CVSS 4.08.8
CNA (VulnCheck)CVSS 3.18.2
Patch
Available – fixed in 4.18.9, 5.11.2
CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:H/VI:L/VA:N/SC:N/SI:N/SA:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 6 Nov 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 6 Nov 2026.

What to do

Upgrade cms to 4.18.9; cms to 5.11.2.

Affected software

ProductAffectedFixed in
craftcmscmsAffected
  • >=4.0.0 <4.18.9
Fixed in
  • 4.18.9
craftcmscmsAffected
  • >=5.0.0 <5.11.2
Fixed in
  • 5.11.2

AI-suggested

Apply the official patches by upgrading Craft CMS to version 4.18.9 or later for the 4.x branch, or to version 5.11.2 or later for the 5.x branch. These versions contain fixes that properly cleanse arguments used in GraphQL eager-loading, eliminating the SQL injection vulnerability.

Description

Craft CMS versions 4.0.0 before 4.18.9 and 5.0.0 before 5.11.2 have an SQL injection vulnerability in the GraphQL eager-loading feature. This flaw allows unauthenticated attackers to inject SQL expressions by supplying crafted arguments, potentially exposing sensitive database content such as password hashes and session tokens. The vulnerability arises because arguments on eager-loadable nodes not present in the public schema are copied into query criteria without proper cleansing. This issue is fixed in versions 4.18.9 and 5.11.2.

References

Community reviews

Loading reviews…