CVE-2026-123613: rustls · Improper Input Validation
Affects rustlsSource CVE Database V5
Not known to be exploited · CVSS 6.9 Medium : upgrade to 0.23.45 when convenient.
Data as of 8 Nov 2026, 01:50 UTC
Thin evidence
One scorer or none| CNA (VulnCheck) | CVSS 4.0 | 6.9 |
|---|---|---|
| CNA (VulnCheck) | CVSS 3.1 | 5.3 |
- Patch
- Available – fixed in 0.23.45
CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:L/VI:N/VA:N/SC:N/SI:N/SA:NExploitation evidence
Disclosed: evidence found.
CVE published 8 Nov 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 7 Nov 2026.
What to do
Upgrade rustls to 0.23.45.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| rustlsrustls | Affected
| Fixed in
|
crates.iorustlspkg:cargo/rustlsOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
Upgrade rustls to version 0.23.45 or later, where this vulnerability is fixed. No other mitigation is indicated or required.
Description
CVE-2026-123613 is a vulnerability in rustls versions from 0.23.13 up to but not including 0.23.45. It involves improper input validation where TLS 1.3 handshake messages are accepted at incorrect encryption levels following a key change in the same record. This flaw allows a peer or on-path attacker to send a plaintext EncryptedExtensions message alongside the ServerHello, which rustls mistakenly accepts as unencrypted.