CVE-2026-123614: imgproxy · Heap-based Buffer Overflow
Affects imgproxySource CVE Database V5
Not known to be exploited · CVSS 9.3 Critical : upgrade to 4.0.16 as a priority.
Data as of 8 Nov 2026, 01:50 UTC
Thin evidence
One scorer or none| CNA (VulnCheck) | CVSS 4.0 | 9.3 |
|---|---|---|
| CNA (VulnCheck) | CVSS 3.1 | 9.8 |
- Patch
- Available – fixed in 4.0.16
CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:NExploitation evidence
Disclosed: evidence found.
CVE published 8 Nov 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 7 Nov 2026.
What to do
Upgrade imgproxy to 4.0.16.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| imgproxyimgproxy | Affected
| Fixed in
|
Goimgproxypkg:golang/imgproxyOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
Upgrade imgproxy to version 4.0.16 or later, where this vulnerability has been fixed. No other mitigation is required as the fix addresses the root cause.
Description
A heap-based buffer overflow vulnerability exists in imgproxy versions 4.0.0 up to but not including 4.0.16. The flaw is due to an integer overflow in the ICO image loader's data_size value, which can cause heap memory corruption. This can lead to process crashes or potentially allow remote code execution.