Skip to main content
VulnerabilityPublished

CVE-2026-123615: imgproxy · Out-of-bounds Write

Affects imgproxySource CVE Database V5

0
Compare

Not known to be exploited · CVSS 8.7 High : upgrade to 4.0.17 soon.

Data as of 8 Nov 2026, 01:50 UTC

CVSS 4.0 base score
8.7High
How severe the flaw is on the 0–10 CVSS scale.

Thin evidence

One scorer or none
CVSS scores by source
CNA (VulnCheck)CVSS 4.08.7
CNA (VulnCheck)CVSS 3.17.5
Patch
Available – fixed in 4.0.17
CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:N/VA:H/SC:N/SI:N/SA:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 8 Nov 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 7 Nov 2026.

What to do

Upgrade imgproxy to 4.0.17.

Affected software

ProductAffectedFixed in
imgproxyimgproxyAffected
  • >=3.3.0 <4.0.17
Fixed in
  • 4.0.17

AI-suggested

Upgrade imgproxy to version 4.0.17 or later, where this vulnerability is fixed. No other mitigation or temporary workaround is indicated.

Description

CVE-2026-123615 is a high-severity vulnerability in imgproxy versions 3.3.0 up to but not including 4.0.17. It involves an out-of-bounds heap read and write in the ICO loader's BMP header reconstruction, which can be triggered by an unauthenticated remote attacker supplying a crafted ICO image. This leads to corruption of adjacent heap chunk metadata and causes a glibc abort that crashes the worker process. The issue is fixed in imgproxy version 4.0.17.

References

Community reviews

Loading reviews…