Skip to main content
VulnerabilityPublished

CVE-2026-123792: sensiolabs symfony · Inefficient Algorithmic Complexity

Affects sensiolabs symfonySource CVE Database V5

0
Compare

Not known to be exploited · CVSS 8.7 High · fixed in 8.1.11 : patch sensiolabs symfony soon.

Data as of 6 Nov 2026, 15:47 UTC

CVSS 4.0 base score
8.7High
How severe the flaw is on the 0–10 CVSS scale.

Thin evidence

One scorer or none
CVSS scores by source
CNA (Checkmarx)CVSS 4.08.7
Patch
Available – fixed in 8.1.11, 7.4.23, 6.4.50 +1
CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:N/VA:H/SC:N/SI:N/SA:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 6 Nov 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 6 Nov 2026.

What to do

Upgrade symfony and symfony/yaml to 8.1.11, 7.4.23, 6.4.50 or 5.4.56.

Affected software

ProductAffectedFixed in
symfonysymfony/yamlAffected
  • >=8.0.0 <8.1.11
Fixed in
  • 8.1.11
symfonysymfony/yamlAffected
  • >=7.0.0 <7.4.23
Fixed in
  • 7.4.23
symfonysymfony/yamlAffected
  • >=6.0.0 <6.4.50
Fixed in
  • 6.4.50
symfonysymfony/yamlAffected
  • <5.4.56
Fixed in
  • 5.4.56
Packagistsymfony/yamlpkg:composer/symfony/yamlOther threatsAffected
  • <5.4.56
  • >=6.0.0 <6.4.50
  • >=7.0.0 <7.4.23
  • >=8.0.0 <8.1.11
Fixed in
  • 5.4.56
  • 6.4.50
  • 7.4.23
  • 8.1.11

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Fixed versions are available: upgrade Symfony to 5.4.56, 6.4.50, 7.4.23, or 8.1.11 or later. Applying these official fixes will resolve the inefficient parsing issue. Until upgraded, restrict or validate YAML input sources, especially for untrusted data. In Symfony 7.4 and later, restrict acceptFormat or disable YAML request payload mapping where possible to reduce exposure. No other vendor advisory mitigation instructions are provided.

Description

CVE-2026-123792 is an inefficient algorithmic complexity vulnerability in the Symfony Yaml component affecting versions prior to 5.4.56, 6.4.50, 7.4.23, and 8.1.11. The vulnerability causes the YAML parser to perform excessive repeated work when processing certain crafted YAML documents, leading to exponential or quadratic parsing time growth. This can keep a PHP process busy for extended periods, potentially causing denial of service. The issue affects any code parsing untrusted YAML with default flags, including some Symfony request payload mappings that accept YAML input without restrictions. The vulnerability is rated high severity with a CVSS 4.0 score of 8.7.

References

Community reviews

Loading reviews…