Skip to main content
VulnerabilityPublished

CVE-2026-123824: sensiolabs symfony · XML External Entity (XXE)

Affects sensiolabs symfonySource CVE Database V5

0
Compare

Mentioned vulnerabilities

Not known to be exploited · CVSS 2.3 Low · fixed in 8.1.11 : update sensiolabs symfony when convenient.

Data as of 6 Nov 2026, 17:40 UTC

CVSS 4.0 base score
2.3Low
How severe the flaw is on the 0–10 CVSS scale.

Thin evidence

One scorer or none
CVSS scores by source
CNA (Checkmarx)CVSS 4.02.3
Patch
Available – fixed in 8.1.11, 7.4.23, 6.4.50 +1
CVSS:4.0/AV:N/AC:L/AT:P/PR:L/UI:N/VC:L/VI:L/VA:L/SC:N/SI:N/SA:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 6 Nov 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 6 Nov 2026.

What to do

Upgrade symfony and symfony/config to 8.1.11, 7.4.23, 6.4.50 or 5.4.56.

Affected software

ProductAffectedFixed in
symfonysymfony/configAffected
  • >=8.0.0 <8.1.11
Fixed in
  • 8.1.11
symfonysymfony/configAffected
  • >=7.0.0 <7.4.23
Fixed in
  • 7.4.23
symfonysymfony/configAffected
  • >=6.0.0 <6.4.50
Fixed in
  • 6.4.50
symfonysymfony/configAffected
  • <5.4.56
Fixed in
  • 5.4.56
Packagistsymfony/configpkg:composer/symfony/configOther threatsAffected
  • <5.4.56
  • >=6.0.0 <6.4.50
  • >=7.0.0 <7.4.23
  • >=8.0.0 <8.1.11
Fixed in
  • 5.4.56
  • 6.4.50
  • 7.4.23
  • 8.1.11

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

A patch is available and has been applied in Symfony versions 5.4.56, 6.4.50, 7.4.23, and 8.1.11. Users should upgrade to these or later versions to remediate the vulnerability. Since this is a server-side library, the vendor manages remediation for cloud-hosted services. Applications should avoid passing untrusted XML to XmlUtils::parse() or ensure input is sanitized. No additional mitigations are specified by the vendor advisory.

Description

CVE-2026-123824 is an XML External Entity (XXE) vulnerability in the Symfony Config component's XmlUtils::parse() method. The method enables DTD validation before rejecting XML documents containing a doctype, allowing attackers to exploit external entity references. This can reveal local file existence, cause denial of service, and potentially exfiltrate local file contents if certain network stream wrappers are registered. The vulnerability affects Symfony versions prior to 5.4.56, 6.4.50, 7.4.23, and 8.1.11. A patch is available in these fixed versions.

References

Community reviews

Loading reviews…