Skip to main content
VulnerabilityPublished

CVE-2026-12609: Eclipse Theia · Path Traversal

Affects Eclipse TheiaSource CVE Database V5

0
Compare

Not known to be exploited · public detection template (Nuclei) · CVSS 7.5 High : upgrade to 1.74.0 soon.

Data as of 3 Nov 2026, 22:58 UTC

CVSS 3.1 base score
7.5High
How severe the flaw is on the 0–10 CVSS scale.
EPSS
1.6% chance of exploitation in 30 days – higher than 76% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 1.74.0
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 5 Aug 2026

  2. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  3. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  4. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 3 Nov 2026.

What to do

Upgrade Eclipse Theia to 1.74.0.

Affected software

ProductAffectedFixed in
Eclipse FoundationEclipse TheiaAffected
  • >=1.66.0 <1.74.0
Fixed in
  • 1.74.0

AI-suggested

If you cannot patch yet, restrict network access to the Eclipse Theia backend to trusted users only and monitor for suspicious requests targeting the /hostedPlugin/ endpoint. Avoid exposing the service to untrusted networks.

Description

Eclipse Theia versions 1.66.0 through 1.73.1 contain a directory traversal vulnerability in the @theia/plugin-ext backend. The HTTP endpoint /hostedPlugin/:pluginId/:path(*) improperly resolves file paths without verifying that the resolved path remains within the plugin directory. This allows unauthenticated network attackers to retrieve arbitrary files readable by the Theia backend process by sending encoded traversal sequences. Plugin IDs are deterministic, enabling attackers to target built-in plugins without prior system knowledge. The vulnerability has a high severity with a CVSS score of 7.5.

References

Community reviews

Loading reviews…