CVE-2026-60009: Eclipse Theia · Cross-Site Request Forgery
Affects Eclipse TheiaSource CVE Database V5
Not known to be exploited · CVSS 8.8 High : upgrade to 1.74.0 soon.
Data as of 3 Nov 2026, 22:58 UTC
- EPSS
- 0.4% chance of exploitation in 30 days – higher than 38% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 1.74.0
CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:HExploitation evidence
Disclosed: evidence found.
CVE published 5 Aug 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 3 Nov 2026.
What to do
Upgrade Eclipse Theia to 1.74.0.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| Eclipse FoundationEclipse Theia | Affected
| Fixed in
|
AI-suggested
If you cannot patch yet, avoid exposing the vulnerable POST /file-upload endpoint in browser deployments or restrict access to trusted origins. Electron mode is not affected by this vulnerability via this path.
Description
Eclipse Theia versions up to and including 1.73.1 have a vulnerability in the @theia/filesystem backend where an unauthenticated attacker can perform arbitrary file writes outside the workspace via a specially crafted POST /file-upload request. This occurs because the handler accepts an absolute path from user input without workspace confinement or authentication. Browser deployments are affected due to insufficient token enforcement on HTTP requests, enabling cross-origin web pages to exploit this without credentials. Electron mode is not affected by this issue. The vulnerability has a high severity CVSS score of 8.8 and can lead to remote code execution by overwriting critical files such as ~/.bashrc.
References
- github.com/eclipse-theia/theia/security/advisories/GHSA-62f6-wcvg-54h3 (opens in a new tab)
- gitlab.eclipse.org/security/vulnerability-reports/-/issues/595 (opens in a new tab)
- gitlab.eclipse.org/security/cve-assignment/-/work_items/177 (opens in a new tab)
- gitlab.eclipse.org/security/vulnerability-reports/-/work_items/595 (opens in a new tab)