CVE-2026-12687: ProfileGrid (WordPress plugin) · Improper Privilege Management
Affects ProfileGrid (WordPress plugin)Source CVE Database V5
Not known to be exploited · CVSS 7.5 High : upgrade to 5.9.9.8 soon.
Data as of 30 Oct 2026, 06:59 UTC
- EPSS
- 0.4% chance of exploitation in 30 days – higher than 34% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 5.9.9.8
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:NExploitation evidence
Disclosed: evidence found.
CVE published 30 Jul 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 29 Oct 2026.
What to do
Upgrade ProfileGrid (WordPress plugin) to 5.9.9.8.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| ProfileGrid | Affected
| Fixed in
|
AI-suggested
If you cannot patch yet, restrict or disable front-end registration or manually monitor and control group memberships to prevent unauthorized privilege escalation.
Description
ProfileGrid WordPress plugin versions before 5.9.9.8 allow unauthenticated users to register into privileged groups via the front-end registration. This flaw permits privilege escalation by assigning the user the role configured for that group, potentially up to Administrator. The vulnerability arises from improper privilege management in group registration restrictions.