Skip to main content
VulnerabilityPublished

CVE-2026-13154: Gutenberg Essential Blocks (WordPress plugin) · Information Exposure

Affects Gutenberg Essential Blocks (WordPress plugin)Source CVE Database V5

0
Compare

Not known to be exploited · CVSS 7.5 High : upgrade to 6.4.0 soon.

Data as of 5 Nov 2026, 00:01 UTC

CVSS 3.1 base score
7.5High
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.4% chance of exploitation in 30 days – higher than 37% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 6.4.0
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 6 Aug 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 5 Nov 2026.

What to do

Upgrade Gutenberg Essential Blocks (WordPress plugin) to 6.4.0.

Affected software

ProductAffectedFixed in
Gutenberg Essential BlocksAffected
  • <6.4.0
Fixed in
  • 6.4.0

AI-suggested

Users should monitor official Gutenberg Essential Blocks plugin updates and apply version 6.4.0 or later once available to remediate this issue. If you cannot patch yet, consider restricting access to the REST API or disabling affected routes if feasible.

Description

A vulnerability in the Gutenberg Essential Blocks WordPress plugin before version 6.4.0 allows unauthenticated users to read published entries of custom post types that are registered as non-public. This occurs because the plugin does not verify that an attacker-supplied post type is publicly viewable before querying it in one of its public REST routes. The vulnerability is classified as CWE-200 (Information Exposure) and has a high severity rating with a CVSS score of 7.5.

References

Community reviews

Loading reviews…