Skip to main content
VulnerabilityPublished

CVE-2026-14824: Quiz and Survey Master (QSM) (WordPress plugin) · Cross-Site Scripting (XSS)

Affects Quiz and Survey Master (QSM) (WordPress plugin)Source CVE Database V5

0
Compare

Not known to be exploited · CVSS 4.8 Medium : upgrade to 11.2.2 when convenient.

Data as of 2 Nov 2026, 22:58 UTC

CVSS 3.1 base score
4.8Medium
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.2% chance of exploitation in 30 days – higher than 15% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 11.2.2
CVSS:3.1/AV:N/AC:L/PR:H/UI:R/S:C/C:L/I:L/A:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 4 Aug 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 2 Nov 2026.

What to do

Upgrade Quiz and Survey Master (QSM) (WordPress plugin) to 11.2.2.

Affected software

ProductAffectedFixed in
Quiz and Survey Master (QSM)Affected
  • <11.2.2
Fixed in
  • 11.2.2

AI-suggested

Since the vulnerability affects versions before 11.2.2, upgrading to version 11.2.2 or later is recommended once the vendor releases a fix. Until then, restrict contributor-level access to trusted users and avoid publishing quizzes created by contributors.

Description

A Cross-Site Scripting (XSS) vulnerability exists in the Quiz and Survey Master (QSM) WordPress plugin before version 11.2.2. This flaw allows users with contributor-level access or higher to inject arbitrary JavaScript into quiz questions, which executes in the browsers of users viewing the affected quiz. The vulnerability arises from improper escaping of question settings before outputting them into an unquoted HTML attribute.

References

Community reviews

Loading reviews…