Skip to main content
VulnerabilityPublished

CVE-2026-14870: Database for Contact Form 7, WPforms, Elementor forms (WordPress plugin) · Cross-Site Scripting (XSS)

Affects Database for Contact Form 7, WPforms, Elementor forms (WordPress plugin)Source CVE Database V5

0

Not known to be exploited · public detection template (Nuclei) · CVSS 7.1 High : upgrade to 1.5.3 soon.

Data as of 27 Oct 2026, 05:11 UTC

CVSS 3.1 base score
7.1High
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.4% chance of exploitation in 30 days – higher than 40% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 1.5.3
CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:L

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 28 Jul 2026

  2. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  3. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  4. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.

What to do

Upgrade Database for Contact Form 7, WPforms, Elementor forms (WordPress plugin) to 1.5.3.

Affected software

ProductAffectedFixed in
Database for Contact Form 7, WPforms, Elementor formsAffected
  • <1.5.3
Fixed in
  • 1.5.3

AI-suggested

Since the vulnerability affects versions before 1.5.3, upgrading to version 1.5.3 or later (if available) is recommended once confirmed. If you cannot patch yet, restrict access to the affected admin pages and avoid clicking on suspicious links that could trigger reflected XSS. Monitor vendor channels for official fixes or temporary mitigations.

Description

The Database for Contact Form 7, WPforms, Elementor forms WordPress plugin before 1.5.3 does not properly sanitise and escape a parameter before reflecting it back in an admin page, leading to a Reflected Cross-Site Scripting which could be used against high privilege users such as admin.

References

Community reviews

Loading reviews…