CVE-2026-15147: Five Star Restaurant Reservations (WordPress plugin) · Insufficient Verification of Data Authenticity
Affects Five Star Restaurant Reservations (WordPress plugin)Source CVE Database V5
Not known to be exploited · CVSS 5.3 Medium : upgrade to 2.7.23 when convenient.
Data as of 5 Nov 2026, 00:01 UTC
- EPSS
- 0.1% chance of exploitation in 30 days – higher than 5% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 2.7.23
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:L/A:NExploitation evidence
Disclosed: evidence found.
CVE published 6 Aug 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 5 Nov 2026.
What to do
Upgrade Five Star Restaurant Reservations (WordPress plugin) to 2.7.23.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| Five Star Restaurant Reservations | Affected
| Fixed in
|
AI-suggested
If you cannot patch yet, users should consider additional manual verification of payment notifications or restrict access to the plugin's payment processing endpoints if possible.
Description
The Five Star Restaurant Reservations WordPress plugin before version 2.7.23 has a vulnerability where it does not verify the authenticity of incoming payment notifications. This flaw allows unauthenticated attackers to mark arbitrary pending reservations as paid and confirmed without validating the payment recipient, amount, status, or binding the notification to the intended booking.