CVE-2026-15151: Five Star Restaurant Reservations (WordPress plugin) · Improper Access Control
Affects Five Star Restaurant Reservations (WordPress plugin)Source CVE Database V5
Not known to be exploited · CVSS 7.5 High : upgrade to 2.7.23 soon.
Data as of 31 Oct 2026, 08:20 UTC
- EPSS
- 0.3% chance of exploitation in 30 days – higher than 33% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 2.7.23
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:NExploitation evidence
Disclosed: evidence found.
CVE published 2 Aug 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 30 Oct 2026.
What to do
Upgrade Five Star Restaurant Reservations (WordPress plugin) to 2.7.23.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| Five Star Restaurant Reservations | Affected
| Fixed in
|
AI-suggested
If you cannot patch yet, restrict booking-management roles to trusted users only and monitor for unauthorized changes to booking notification settings.
Description
The Five Star Restaurant Reservations WordPress plugin before version 2.7.23 contains an improper access control vulnerability. This flaw allows users with the lowest booking-management role, who normally cannot access the plugin's settings, to reset the site's booking notification rules via an unprotected AJAX action.