CVE-2026-15230: YayPricing (WordPress plugin) · Improper Access Control
Affects YayPricing (WordPress plugin)Source CVE Database V5
Not known to be exploited · CVSS 8.1 High : upgrade to 3.5.7 soon.
Data as of 3 Nov 2026, 10:57 UTC
- EPSS
- 0.3% chance of exploitation in 30 days – higher than 28% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 3.5.7
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:NExploitation evidence
Disclosed: evidence found.
CVE published 5 Aug 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 3 Nov 2026.
What to do
Upgrade YayPricing (WordPress plugin) to 3.5.7.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| YayPricing | Affected
| Fixed in
|
AI-suggested
If you cannot patch yet, restrict access to the REST API routes in question by limiting authenticated user roles or applying custom capability checks.
Description
YayPricing WordPress plugin versions before 3.5.7 have an improper access control vulnerability in several REST API routes. The plugin relies solely on a shared nonce without performing proper capability checks, allowing any authenticated user, including subscribers, to overwrite store pricing configurations and disclose private coupon codes. This vulnerability has a high severity score of 8.1 and impacts confidentiality and integrity but not availability.