CVE-2026-87888: YayPricing (WordPress plugin) · Cross-Site Scripting (XSS)
Affects YayPricing (WordPress plugin)Source CVE Database V5
Not known to be exploited · CVSS 8.0 High : upgrade to 3.5.7 soon.
Data as of 28 Oct 2026, 05:12 UTC
- EPSS
- 0.4% chance of exploitation in 30 days – higher than 35% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 3.5.7
CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:U/C:H/I:H/A:HExploitation evidence
Disclosed: evidence found.
CVE published 12 Sep 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponised: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.
What to do
Upgrade YayPricing (WordPress plugin) to 3.5.7.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| YayPricing | Affected
| Fixed in
|
AI-suggested
A fix is available in YayPricing version 3.5.7 and later. Users should upgrade to version 3.5.7 or above to remediate this vulnerability. Until then, restrict subscriber-level users from accessing the affected REST route or the plugin settings page if possible.
Description
The YayPricing WordPress plugin before 3.5.7 does not perform an authorization check on a REST route that saves its pricing rules, allowing users with the subscriber role and above to store JavaScript that executes in the browser of an administrator who opens the YayPricing WordPress plugin before 3.5.7's settings page.