Skip to main content
VulnerabilityPublished

CVE-2026-15239: Simple CAPTCHA with Cloudflare Turnstile (WordPress plugin) · Insufficient Verification of Data Authenticity

Affects Simple CAPTCHA with Cloudflare Turnstile (WordPress plugin)Source CVE Database V5

0
Compare

Not known to be exploited · CVSS 5.3 Medium : upgrade to 1.42.0 when convenient.

Data as of 5 Nov 2026, 00:01 UTC

CVSS 3.1 base score
5.3Medium
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.1% chance of exploitation in 30 days – higher than 4% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 1.42.0
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:L/A:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 7 Aug 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 5 Nov 2026.

What to do

Upgrade Simple CAPTCHA with Cloudflare Turnstile (WordPress plugin) to 1.42.0.

Affected software

ProductAffectedFixed in
Simple CAPTCHA with Cloudflare TurnstileAffected
  • <1.42.0
Fixed in
  • 1.42.0

AI-suggested

A patch is available for Simple CAPTCHA with Cloudflare Turnstile plugin version 1.42.0 and later that fixes this vulnerability. Users should upgrade to version 1.42.0 or newer to remediate the issue. Since this is a cloud service plugin, the vendor manages remediation for the cloud-hosted service. Check the vendor advisory for confirmation and apply the official update promptly.

Description

The Simple CAPTCHA with Cloudflare Turnstile WordPress plugin versions prior to 1.42.0 contains a vulnerability where its Turnstile validation cache is not properly bound to the single-use challenge token. This allows unauthenticated attackers to solve one CAPTCHA challenge and then replay token-less form submissions within a short time window, bypassing the anti-abuse protection. The vulnerability is identified as CWE-345: Insufficient Verification of Data Authenticity. A patch is available to address this issue.

References

Community reviews

Loading reviews…