CVE-2026-15386: Meow Gallery (WordPress plugin) · Cross-Site Scripting (XSS)
Affects Meow Gallery (WordPress plugin)Source CVE Database V5
Not known to be exploited · CVSS 5.4 Medium : upgrade to 5.5.2 when convenient.
Data as of 5 Nov 2026, 00:01 UTC
- EPSS
- 0.2% chance of exploitation in 30 days – higher than 13% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 5.5.2
CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:NExploitation evidence
Disclosed: evidence found.
CVE published 7 Aug 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 5 Nov 2026.
What to do
Upgrade Meow Gallery (WordPress plugin) to 5.5.2.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| Meow Gallery | Affected
| Fixed in
|
AI-suggested
If you cannot patch yet, restrict Author role permissions to trusted users only and consider removing or disabling linked galleries that use attachment alt text. Monitor for plugin updates from the vendor addressing this issue.
Description
CVE-2026-15386 is a cross-site scripting (XSS) vulnerability in the Meow Gallery WordPress plugin before version 5.5.2. It occurs because the plugin does not properly escape an attachment's alt text before outputting it into a link attribute for linked galleries. This allows users with Author role or higher to inject JavaScript payloads that execute in the browsers of visitors who view posts containing the affected galleries.