Skip to main content
VulnerabilityPublished

CVE-2026-96677: Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in

Source GCVE Database

0
Compare
Authoritative record:CVE-2026-96677· Critical 10.0

Not known to be exploited · CVSS 10.0 Critical : upgrade to 9.2.1 as a priority.

Data as of 5 Nov 2026, 13:07 UTC

CVSS 4.0 base score
10.0Critical
How severe the flaw is on the 0–10 CVSS scale.

Thin evidence

One scorer or none
CVSS scores by source
CNA (apache)CVSS 4.010.0
Patch
Available – fixed in 9.2.1
CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:H/VI:H/VA:H/SC:H/SI:H/SA:H

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 5 Nov 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 5 Nov 2026.

What to do

Upgrade Apache Juneau and org.apache.juneau/juneau-marshall to 9.2.1.

Affected software

ProductAffectedFixed in
Apache Juneauorg.apache.juneau:juneau-marshallAffected
  • <9.2.1
Fixed in
  • 9.2.1
Mavenorg.apache.juneau/juneau-marshallpkg:maven/org.apache.juneau/juneau-marshallOther threatsAffected
  • <9.2.1
Fixed in
  • 9.2.1

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Users should upgrade Apache Juneau to version 9.2.1, which contains the official fix for this vulnerability. Applications that do not include request-derived variables in the page chrome are not affected. No other mitigations are specified or required beyond applying the official update.

Description

Apache Juneau versions through 9.2.0 have a cross-site scripting (XSS) vulnerability due to improper HTML encoding of variable substitutions in page chrome elements. This affects applications that include request-derived variables in the chrome, such as headers or form data, reflecting unencoded input and enabling XSS attacks. The default chrome does not use request variables, so only customized applications are impacted. The issue is fixed in version 9.2.1.

References

Community reviews

Loading reviews…