Skip to main content
VulnerabilityPublished

CVE-2026-15958: Easy Integration for Dropbox (WordPress plugin) · Missing Authorization

Affects Easy Integration for Dropbox (WordPress plugin)Source CVE Database V5

0
Compare

Not known to be exploited · CVSS 9.3 Critical : upgrade to 2.2.0 as a priority.

Data as of 2 Nov 2026, 22:58 UTC

CVSS 3.1 base score
9.3Critical
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.3% chance of exploitation in 30 days – higher than 28% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 2.2.0
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:C/C:H/I:L/A:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 4 Aug 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 2 Nov 2026.

What to do

Upgrade Easy Integration for Dropbox (WordPress plugin) to 2.2.0.

Affected software

ProductAffectedFixed in
Easy Integration for DropboxAffected
  • <2.2.0
Fixed in
  • 2.2.0

AI-suggested

If you cannot patch yet, restrict access to the affected AJAX endpoints or disable the plugin if possible.

Description

Easy Integration for Dropbox WordPress plugin versions before 2.2.0 contain a critical vulnerability due to missing authorization checks on several file-management AJAX actions. These actions are accessible to unauthenticated users, allowing attackers to list, download, and upload arbitrary files in the connected Dropbox account and access sensitive email addresses.

References

Community reviews

Loading reviews…