CVE-2026-16030: MStore API (WordPress plugin) · Improper Authentication
Affects MStore API (WordPress plugin)Source CVE Database V5
Not known to be exploited · CVSS 8.1 High : upgrade to 4.21.0 soon.
Data as of 5 Nov 2026, 00:01 UTC
- EPSS
- 0.3% chance of exploitation in 30 days – higher than 32% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 4.21.0
CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:HExploitation evidence
Disclosed: evidence found.
CVE published 7 Aug 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 5 Nov 2026.
What to do
Upgrade MStore API (WordPress plugin) to 4.21.0.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| MStore API | Affected
| Fixed in
|
AI-suggested
If you cannot patch yet, restrict access to the plugin's phone-based login feature if possible, and monitor for suspicious activity related to account logins.
Description
CVE-2026-16030 is a high-severity vulnerability in the MStore API WordPress plugin before version 4.21.0. It involves improper authentication due to incorrect verification of the cryptographic signature of tokens used for phone-based login. This flaw allows unauthenticated attackers who know a registered user's phone number to forge authentication tokens and take over that user's account, including administrator accounts.