Skip to main content
VulnerabilityPublished

CVE-2026-16038: MStore API (WordPress plugin) · Missing Authorization

Affects MStore API (WordPress plugin)Source CVE Database V5

0
Compare

Not known to be exploited · CVSS 9.1 Critical : upgrade to 4.21.0 as a priority.

Data as of 5 Nov 2026, 00:01 UTC

CVSS 3.1 base score
9.1Critical
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.4% chance of exploitation in 30 days – higher than 36% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 4.21.0
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 7 Aug 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 5 Nov 2026.

What to do

Upgrade MStore API (WordPress plugin) to 4.21.0.

Affected software

ProductAffectedFixed in
MStore APIAffected
  • <4.21.0
Fixed in
  • 4.21.0

AI-suggested

If you cannot patch yet, restrict access to payment-completion endpoints and monitor for suspicious activity related to order status changes.

Description

The MStore API WordPress plugin before version 4.21.0 contains a missing authorization vulnerability in its payment-completion endpoints. This flaw allows unauthenticated attackers to mark arbitrary orders as paid without verifying payment with the payment gateway, potentially enabling free acquisition of goods or services.

References

Community reviews

Loading reviews…