Skip to main content
VulnerabilityPublished Updated

CVE-2026-16463: Autodesk AutoCAD · Heap-based Buffer Overflow

Affects Autodesk AutoCADSource CVE Database V5

0

Not known to be exploited · CVSS 7.8 High : upgrade to 2027.1.0 soon.

Data as of 28 Oct 2026, 05:11 UTC

CVSS 3.1 base score
7.8High
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.2% chance of exploitation in 30 days – higher than 20% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 2027.1.0
CVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 29 Jul 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.

What to do

Upgrade AutoCAD and AutoCAD LT and DWG TrueView to 2027.1.0.

Affected software

ProductAffectedFixed in
AutodeskAutoCADAffected
  • >=2027.0.0 <2027.1.0
Fixed in
  • 2027.1.0
AutodeskAutoCAD LTAffected
  • >=2027.0.0 <2027.1.0
Fixed in
  • 2027.1.0
AutodeskDWG TrueViewAffected
  • >=2027.0.0 <2027.1.0
Fixed in
  • 2027.1.0

CPE configurations (3)

  • cpe:2.3:a:autodesk:autocad:2027:*:*:*:*:*:*:*
  • cpe:2.3:a:autodesk:autocad_lt:2027:*:*:*:*:*:*:*
  • cpe:2.3:a:autodesk:dwg_trueview:2027:*:*:*:*:*:*:*

AI-suggested

If you cannot patch yet, avoid opening untrusted DXF files and restrict access to AutoCAD to trusted users only.

Description

A maliciously crafted DXF file, when parsed through Autodesk AutoCAD, can force a Heap-Based Overflow vulnerability. A malicious actor can leverage this vulnerability to cause a crash, read sensitive data, or execute arbitrary code in the context of the current process.

References

Community reviews

Loading reviews…