Skip to main content
VulnerabilityPublished Updated

CVE-2026-16535: Link Library (WordPress plugin) · Cross-Site Scripting (XSS)

Affects Link Library (WordPress plugin)Source CVE Database V5

0
Compare

Not known to be exploited · public detection template (Nuclei) · CVSS 6.1 Medium : upgrade to 7.9.4 when convenient.

Data as of 7 Nov 2026, 23:24 UTC

CVSS 3.1 base score
6.1Medium
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.5% chance of exploitation in 30 days – higher than 43% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 7.9.4
CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 8 Aug 2026

  2. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  3. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  4. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 7 Nov 2026.

What to do

Upgrade Link Library (WordPress plugin) to 7.9.4.

Affected software

ProductAffectedFixed in
Link LibraryAffected
  • <7.9.4
Fixed in
  • 7.9.4

AI-suggested

If you cannot patch yet, avoid clicking on suspicious links related to the Link Library plugin and consider disabling or restricting the plugin if possible.

Description

The Link Library WordPress plugin before 7.9.4 does not sanitise and escape a parameter before reflecting it back in a response, allowing unauthenticated attackers to perform Reflected Cross-Site Scripting attacks against users who can be tricked into performing an action.

References

Community reviews

Loading reviews…