Skip to main content
VulnerabilityPublished

CVE-2026-18197: Link Library · Cross-site Scripting

Affects Link LibrarySource CVE Database V5

0

Not known to be exploited · CVSS 6.4 Medium : upgrade to 7.9.4 when convenient.

Data as of 27 Oct 2026, 17:11 UTC

CVSS 4.0 base score
6.4Medium
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.2% chance of exploitation in 30 days – higher than 19% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 7.9.4
CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:A/VC:L/VI:L/VA:N/SC:H/SI:H/SA:H

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 29 Jul 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.

What to do

Upgrade Link Library to 7.9.4.

Affected software

ProductAffectedFixed in
Link LibraryAffected
  • <7.9.4
Fixed in
  • 7.9.4

AI-suggested

If you cannot patch yet, consider applying input validation or output encoding controls if feasible to mitigate XSS risks.

Description

CVE-2026-18197 is a cross-site scripting (XSS) vulnerability in Link Library that results from improper neutralization of input during web page generation. This vulnerability affects versions of Link Library prior to 7.9.4. The issue allows an attacker to inject malicious scripts into web pages viewed by other users. The CVSS 4.0 base score is 6.4, indicating a medium severity level.

References

Community reviews

Loading reviews…