CVE-2026-16636: FluentSMTP (WordPress plugin) · Cross-site Scripting
Affects FluentSMTP (WordPress plugin)Source CVE Database V5
Not known to be exploited · CVSS 7.2 High · patch available : patch FluentSMTP (WordPress plugin) soon.
Data as of 5 Nov 2026, 00:01 UTC
- EPSS
- 0.5% chance of exploitation in 30 days – higher than 45% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:C/C:L/I:L/A:NExploitation evidence
Disclosed: evidence found.
CVE published 6 Aug 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 5 Nov 2026.
What to do
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| wpmanageninjaFluentSMTP – WP SMTP Plugin with Amazon SES, SendGrid, Mailgun, Postmark, Cloudflare, toSend, Gmail and Any SMTP | Affected
| Fixed in– |
AI-suggested
A patch is available for this vulnerability. Since the product is a cloud service, the vendor manages remediation on the server side. Administrators should verify that their FluentSMTP plugin is updated beyond version 2.2.95 or confirm with the vendor that the service has been patched. No additional mitigation steps are required if the patch is applied.
Description
The FluentSMTP – WP SMTP Plugin with Amazon SES, SendGrid, MailGun, Postmark, Google and Any SMTP Provider plugin for WordPress is vulnerable to Stored Cross-Site Scripting via Recipient Display Name (to.name) in Email Logs in all versions up to, and including, 2.2.95 due to insufficient input sanitization and output escaping. This makes it possible for unauthenticated attackers to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page. The payload is delivered via an attacker-controlled recipient display name (to.name) in a wp_mail() call and does not fire in the log list view — only in the detail view when an administrator uses the Prev/Next navigation controls, as that path bypasses the escapeHtml pipeline used by the list view.
References
- wordfence.com/threat-intel/vulnerabilities/id/4ad3ed6b-19d4-47c7-a56c-54092c767fe9?source=cve (opens in a new tab)
- plugins.trac.wordpress.org/browser/fluent-smtp/tags/2.2.95/assets/admin/js/fluent-mail-admin-app.js (opens in a new tab)
- plugins.trac.wordpress.org/browser/fluent-smtp/tags/2.2.95/app/Services/Mailer/BaseHandler.php (opens in a new tab)
- plugins.trac.wordpress.org/browser/fluent-smtp/tags/2.2.95/app/Models/Logger.php (opens in a new tab)
- plugins.trac.wordpress.org/browser/fluent-smtp/tags/2.2.95/app/Models/Logger.php (opens in a new tab)
- plugins.trac.wordpress.org/browser/fluent-smtp/tags/2.2.95/app/Services/Mailer/BaseHandler.php (opens in a new tab)
- plugins.trac.wordpress.org/changeset?reponame=&new=3635135%40fluent-smtp%2Ftags%2F2.3.0&old=3428610%40fluent-smtp%2Ftags%2F2.2.95 (opens in a new tab)
- plugins.trac.wordpress.org/changeset/3635135/fluent-smtp/trunk/assets/admin/js/fluent-mail-admin-app.js (opens in a new tab)
- plugins.trac.wordpress.org/changeset?old_path=%2Ffluent-smtp/tags/2.2.95&new_path=%2Ffluent-smtp/tags/2.3.0 (opens in a new tab)