CVE-2026-17556: GitHub Enterprise Server · Path Traversal
Affects GitHub Enterprise ServerSource CVE Database V5
Not known to be exploited · CVSS 8.8 High · fixed in 3.21.4 : patch GitHub Enterprise Server soon.
Data as of 3 Nov 2026, 22:58 UTC
- EPSS
- 0.8% chance of exploitation in 30 days – higher than 56% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 3.21.4
CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:H/VA:H/SC:N/SI:N/SA:NExploitation evidence
Disclosed: evidence found.
CVE published 5 Aug 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 3 Nov 2026.
What to do
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| GitHubEnterprise Server | Affected
| Fixed in– |
AI-suggested
This vulnerability has been fixed in GitHub Enterprise Server versions 3.21.4, 3.20.6, 3.19.10, 3.18.13, and 3.17.19. Users should upgrade to one of these fixed versions or later to remediate the issue. Since this is not a cloud service, patching the affected software is required. There is no indication that any temporary or alternative mitigations are available or recommended.
Description
CVE-2026-17556 is a path traversal vulnerability in GitHub Enterprise Server that allows unauthenticated attackers to delete arbitrary files and directories on the affected instance. The flaw arises from improper sanitization of the X-GitHub-Request-Id header, which is used as a filesystem path segment, enabling traversal to arbitrary paths. Exploitation requires only network access and works even when private mode is enabled. The vulnerability affects versions prior to 3.22 and was fixed in several patch releases including 3.21.4, 3.20.6, 3.19.10, 3.18.13, and 3.17.19. It was reported through the GitHub Bug Bounty program and has a high CVSS 4.0 score of 8.8.
References
- docs.github.com/en/enterprise-server@3.17/admin/release-notes (opens in a new tab)
- docs.github.com/en/enterprise-server@3.18/admin/release-notes (opens in a new tab)
- docs.github.com/en/enterprise-server@3.19/admin/release-notes (opens in a new tab)
- docs.github.com/en/enterprise-server@3.20/admin/release-notes (opens in a new tab)
- docs.github.com/en/enterprise-server@3.21/admin/release-notes (opens in a new tab)