CVE-2026-17569: Devolutions Server · Insufficiently Protected Credentials
Affects Devolutions ServerSource CVE Database V5
Not known to be exploited · CVSS 4.3 Medium : upgrade to 2026.2.14 or 2026.1.24 when convenient.
Data as of 27 Oct 2026, 05:11 UTC
- EPSS
- 0.2% chance of exploitation in 30 days – higher than 19% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 2026.2.14, 2026.1.24
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:N/A:NExploitation evidence
Disclosed: evidence found.
CVE published 27 Jul 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponised: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.
What to do
Upgrade Devolutions Server to 2026.2.14 or 2026.1.24.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| DevolutionsServer | Affected
| Fixed in
|
| DevolutionsServer | Affected
| Fixed in
|
AI-suggested
If you cannot patch yet, restrict user permissions carefully and monitor access to sensitive API tokens. Avoid granting unnecessary view permissions on entries that contain sensitive credentials.
Description
Improper access control in the NetBox synchronizer in Devolutions Server allows an authenticated user with view-only permission on an entry to obtain a stored API token via the partial connection endpoint. This issue affects : * Devolutions Server 2026.2.4.0 through 2026.2.12.0 * Devolutions Server 2026.1.23.0 and earlier