CVE-2026-18022: pgvector · Integer Overflow or Wraparound
Affects pgvectorSource CVE Database V5
Not known to be exploited · CVSS 8.8 High : upgrade to 0.8.6 soon.
Data as of 27 Oct 2026, 17:11 UTC
- EPSS
- 0.6% chance of exploitation in 30 days – higher than 48% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 0.8.6
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:HExploitation evidence
Disclosed: evidence found.
CVE published 29 Jul 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponised: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.
What to do
Upgrade pgvector and pgvector/pgvector to 0.8.6.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| pgvector | Affected
| Fixed in
|
GitHubpgvector/pgvectorpkg:github/pgvector/pgvectorOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
Users should monitor for official updates from the pgvector maintainers and apply patches once available. Until then, consider restricting database user privileges on 32-bit systems to limit potential exploitation.
Description
Integer wraparound in IVFFlat index build in pgvector before 0.8.6 allows a database user to write data out-of-bounds, which could lead to arbitrary code execution. Only 32-bit systems are affected.