CVE-2026-3172: pgvector · Integer Underflow or Wraparound
Affects pgvectorSource CVE Database V5
Not known to be exploited · CVSS 8.1 High : upgrade to 0.8.2 soon.
Data as of 30 Oct 2026, 06:59 UTC
- EPSS
- 0.3% chance of exploitation in 30 days – higher than 32% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 0.8.2
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:N/A:HExploitation evidence
Disclosed: evidence found.
CVE published 25 Feb 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 29 Oct 2026.
What to do
Upgrade pgvector to 0.8.2.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| pgvector | Affected
| Fixed in
|
GitHubpgvector/pgvectorpkg:github/pgvector/pgvectorOther threats | Affected
| Fixed in– |
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
- Upgrade pgvector to the latest patched version once it is released by the maintainers to address CVE-2026-3172.
- If you cannot patch yet, restrict database user privileges to the minimum necessary, especially limiting access to pgvector features and the ability to build or rebuild HNSW indexes.
- Monitor database logs and audit trails for unusual activity related to index builds or access patterns that could indicate exploitation attempts.
- Implement network segmentation and firewall rules to limit access to PostgreSQL servers running pgvector, reducing exposure to untrusted users.
- Consider disabling parallel HNSW index builds if configurable, or temporarily avoid using pgvector for vector similarity searches in sensitive environments.
- Conduct internal penetration testing and code reviews focusing on pgvector usage to identify potential exploitation vectors.
- Educate database administrators and developers about this vulnerability and the importance of applying updates promptly.
- Employ runtime protections such as memory safety tools or database activity monitoring solutions to detect and prevent buffer overflow exploitation attempts.
Description
Buffer overflow in parallel HNSW index build in pgvector 0.6.0 through 0.8.1 allows a database user to leak sensitive data from other relations or crash the database server.